for sure .fromJson() would be a good name since it’s an object created from the JSON response. But I thought ‘myJson’ was a nice way to keep it very clear to beginners what exactly was getting passed into that next then block, since I remember that wasn’t super clear when we were learning about it. It’s the object we made from the JSON from the response, not the actual response again. I think I could’ve called it ‘myJsonResponse’ or something, but I like to try and keep variable names short-ish. Good variable names are one of those things that are tough to really nail.